Long Island Shooters Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
5,057 Posts
Discussion Starter · #1 ·
Yamaha C90 2 stroke telltale
finally got around to starting it up this year. Engine turned over almost immediately. But same ole, same ole. No pissing from the double ear earmuffs with the garden hose draped over the transom and some water squirted in (as a primer,lol) through the piss hole.
Just like last year and the year before I ended up raising the OD, sticking it into a garbage can which I filled with water. Turned over without any choke at all and telltale pissing just like brand new. Now I put those muffs over the "vents" just above the skeg and prop, but there are another set of vents just above the anti cavitation plate. I thought those higher vents were exhaust though, and did not need to be submerged or "muffed." Anyone ? ( I can't have been doing too much wrong, the Sea Pro and the Yamaha are 1999s, bought new, but the fact that the first time every year (and only the first time) that I have to do the garbage can trick just mystifies me. )
 

·
Registered
Joined
·
278 Posts
I have 2 - 2000 Mercury 150 saltwaters on my sportcraft..... both had new power heads when I boat the boat...... I know they are different makes, but your description sounds similar. two months ago I had both lower units serviced and the impellors replaces with new housing. put on the muffs to test before dropping her in for the season and I experienced the same problem, no water coming through the pissers on either outboard. Finally was able to start and run the engines after throwing the hose into the rinse out port and dropped her in about a month ago. both engines running great and pissing nicely. never did figure out why they weren't pissing with the muffs, but it just wasn't worth my time since the rinse out port worked well..... on the other hand, my previous boat was a 1996 striper with a 96 150 Johnson that pissed without even having it running...... not trying to hijack your thread, just wanted to let you know you aren't alone and would like to see if anyone else knows why this occurs.
 

·
Registered
Joined
·
2,643 Posts
Muffs are so old school. Cant believe in 1999 they were still using that design
. My evinrude has a quick connect port almost like am air compressor for the hose to flush the engine
 

·
Registered
Joined
·
5,057 Posts
Discussion Starter · #4 ·
thanks for the help. Its not an Evinrude, lol.
 

·
Registered
Joined
·
5,057 Posts
Discussion Starter · #6 ·
C90, no fitting
 

·
Registered
Joined
·
5,057 Posts
Discussion Starter · #8 ·
No real complaints. The Yammie is after all, a 1999.
 

·
Registered
Joined
·
2,643 Posts
Those yammies sure do idle a lot smoother than the Evinrude, thats for sure
 

·
Registered
Joined
·
629 Posts
Love Yamaha & Honda's! I have a 1999 115 Johnson that doesn't piss well with muffs but great in the water. Sorry I can't add more than that.
 

·
Registered
Joined
·
278 Posts
Those yammies sure do idle a lot smoother than the Evinrude, thats for sure
That's the one thing I lack with the merc's is the super quiet idle. Those new Evinrudes are gorgeous though
 
1 - 12 of 12 Posts
Top