Long Island Shooters Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
716 Posts
Discussion Starter · #1 ·
I would really appreciate if someone experienced with bolt action could help me. My savage 110 all of a sudden was misfiring half the ammo I was feeding it. I was using regular remington corelokt. I brought the rifle to tnt where I got it and they told me that the hits on the ammo were good hits and its not the rifle, but I got the feeling they just didnt feel like helping. I took apart the bolt assembly amd cleaned it but it is still happening. The hits do look solid but it cant be that cases of  remington are all no good. I am hoping someone has some advice or.might be willing to take a look at it. I love the gun and its driving me nuts that im having this issue
 

·
Putin, the new Ceasar. Veni,Vidi, Vici!
Joined
·
22,005 Posts
Did you try a different batch/brand of ammo? If that doesn't help, order a new pin and spring. They are not restricted parts and you should have no problem getting them.
 

·
Banned
Joined
·
6,423 Posts
Mad Russian said:
Did you try a different batch/brand of ammo? If that doesn't help, order a new pin and spring. They are not restricted parts and you should have no problem getting them.
+1
Try different ammo. Remington could have a bad batch of primers or less sensitive primers. Otherwise the spring and pin are an easy cheap change.
 

·
Registered
Joined
·
716 Posts
Discussion Starter · #4 ·
I ran a box of federal with no problem but I never had issues with remington before. I am hoping I put the bolt assembly pin and spring back together cotrectly
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top